Error when installing bench repo

I trying to install new erpnext on my centos installed pc

so i have ran this commands

git clone bench-repo
pip install --user -e bench-repo

then when i tried to type

bench init frappe-bench && cd frappe-bench

i get this error

bench.utils.CommandFailedError: ./env/bin/pip -q install --upgrade pip

after i deleted the folder where bench repo is installed and created a new folder and then i done like above

this bench.utils.CommandFailedError: ./env/bin/pip -q install --upgrade pip is gone but instead

i getting this error

bench.utils.CommandFailedError: frappe-bench/env/bin/pip install -q -e frappe-bench/apps/frappe --no-cache-dir

Can you post the entire error log please @shahid_ecit

@codingCoffee now i am note getting this error when i tried to install but this happen often so when ever this error comes i will post it it here frappe INFO:bench.utils:frappe-bench/env/bin/pip install -q -e frappe-bench/apps/frappe --no-cache-dir Command "/home/osboxes/frappe-bench/env/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-iyz63Z/scandir/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-9d5Y8y-record/install-record.txt --single-version-externally-managed --compile --install-headers /home/osboxes/frappe-bench/env/include/site/python2.7/scandir" failed with error code 1 in /tmp/pip-build-iyz63Z/scandir/ Traceback (most recent call last): File "/home/osboxes/.local/bin/bench", line 9, in <module> load_entry_point('bench==4.1.0', 'console_scripts', 'bench')() File "/home/osboxes/bench-repo/bench/", line 40, in cli bench_command() File "/home/osboxes/.local/lib/python2.7/site-packages/click/", line 722, in __call__ return self.main(*args, **kwargs) File "/home/osboxes/.local/lib/python2.7/site-packages/click/", line 697, in main rv = self.invoke(ctx) File "/home/osboxes/.local/lib/python2.7/site-packages/click/", line 1066, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File "/home/osboxes/.local/lib/python2.7/site-packages/click/", line 895, in invoke return ctx.invoke(self.callback, **ctx.params) File "/home/osboxes/.local/lib/python2.7/site-packages/click/", line 535, in invoke return callback(*args, **kwargs) File "/home/osboxes/bench-repo/bench/commands/", line 21, in init verbose=verbose, clone_from=clone_from, skip_bench_mkdir=skip_bench_mkdir, skip_redis_config_generation=skip_redis_config_generation) File "/home/osboxes/bench-repo/bench/", line 64, in init get_app(frappe_path, branch=frappe_branch, bench_path=path, build_asset_files=False, verbose=verbose) File "/home/osboxes/bench-repo/bench/", line 76, in get_app install_app(app=app_name, bench_path=bench_path, verbose=verbose) File "/home/osboxes/bench-repo/bench/", line 107, in install_app find_links=find_links)) File "/home/osboxes/bench-repo/bench/", line 140, in exec_cmd raise CommandFailedError(cmd) bench.utils.CommandFailedError: frappe-bench/env/bin/pip install -q -e frappe-bench/apps/frappe --no-cache-dir

1 Like

I get this error

1 Like

It seems like a temporary problem to me, and has got nothing to do with Frappe.

Try installing again and make sure you have the python-dev package,
using the command sudo apt-get install python-dev if you’re on Ubuntu or
sudo yum install python-devel if you’re on CentOS.
Try deleting the frappe-bench directory and installing again using bench init frappe-bench --verbose and posting the error log if you get any.

1 Like