Error when installing new site for new app

I created new application. And then tried to create new site. Error message says:

➜ frappe-bench bench new-site NGO
Traceback (most recent call last):
File “/usr/local/Cellar/python/2.7.9/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 162, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/local/Cellar/python/2.7.9/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/Users/haitham/frappe-bench/apps/frappe/frappe/utils/”, line 79, in
File “/Users/haitham/frappe-bench/apps/frappe/frappe/utils/”, line 16, in main
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 664, in call
return self.main(*args, **kwargs)
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 644, in main
rv = self.invoke(ctx)
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 991, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 991, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 837, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/Users/haitham/frappe-bench/env/lib/python2.7/site-packages/click/”, line 464, in invoke
return callback(*args, **kwargs)
File “/Users/haitham/frappe-bench/apps/frappe/frappe/”, line 68, in new_site
File “/Users/haitham/frappe-bench/apps/frappe/frappe/”, line 142, in init
File “/Users/haitham/frappe-bench/apps/frappe/frappe/”, line 733, in setup_module_map
for module in get_module_list(app):
File “/Users/haitham/frappe-bench/apps/frappe/frappe/”, line 637, in get_module_list
return get_file_items(os.path.join(os.path.dirname(get_module(app_name).file), “modules.txt”))
File “/Users/haitham/frappe-bench/apps/frappe/frappe/”, line 595, in get_module
return importlib.import_module(modulename)
File “/usr/local/Cellar/python/2.7.9/Frameworks/Python.framework/Versions/2.7/lib/python2.7/importlib/”, line 37, in import_module
ImportError: No module named NGO

Seems like your application has an error (btw, app names have to be small case only)

To correct exiting application:

  1. I edited app name and label in the and hooks file.

still there was error when tried to add new-site.

Then I removed folder for that app, and added new app, with app name in small letters. still when try adding new-site, getting same error message.

From where I can check module name? If I check module.txt in the app folder, module name is correctly there.

Neither I am able to fix current app. Not able to add new-site for new-app.