Error when running "pip install --user -e bench-repo"

I am getting this problem when I am following this page: to install Frappe Bench on my macOS.

I get this outcome in my terminal when I run “pip install --user -e bench-repo” in the terminal:

Traceback (most recent call last):
File “/usr/local/bin/pip”, line 6, in
from pkg_resources import load_entry_point
File “/usr/local/lib/python2.7/site-packages/pkg_resources/”, line 26, in
import zipfile
ImportError: No module named zipfile

can anyone kindly help me?

Hey, there’s no need to install bench that way anymore.

You can just skip this part and install bench using pip:

$ pip install --user frappe-bench

then you can move on to setting up sites and stuff.

EDIT: the documentation has been updated and is pending review.

1 Like

I am completely new to this! I run the pip command above, but I get “Command not found: pip”
There is a problem with the pip . I have python, python2, and python3 but I dont not have pip1, pip2 but I have pip3.

wondering if this is the cause

Haha, sometimes systems do not have pip corresponding to the python version installed on the system. And more often than not, these versioned pip binaries (eg. pip3) is symlinked to pip. In your case it wasn’t. So you can just use pip3 instead of pip in the command mentioned above and it should work fine.


For this, you just need to add the directory it specifies to your $PATH environment variable. You can look it up on how to do that.

I hope this helps.

Thank you so much for the help @chinmaypai