Error while bench restart --web --supervisor

frappe@vmi820304:~/frappe-bench$ bench restart --web --supervisor
[sudo] password for frappe: 
$ sudo supervisorctl restart frappe-bench-web:
frappe-bench-web:frappe-bench-frappe-web: stopped
frappe-bench-web:frappe-bench-node-socketio: ERROR (no such file)
frappe-bench-web:frappe-bench-frappe-web: started
ERROR: sudo supervisorctl restart frappe-bench-web:
subprocess.CalledProcessError: Command 'sudo supervisorctl restart frappe-bench-web:    ' returned non-zero exit status 1.

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/local/bin/bench", line 8, in <module>
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 132, in cli
  File "/usr/local/lib/python3.10/dist-packages/bench/commands/", line 41, in restart
    Bench(".").reload(web, supervisor, systemd)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 126, in wrapper_fn
    return fn(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 152, in reload
    restart_supervisor_processes(, web_workers=web, _raise=_raise)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 321, in restart_supervisor_processes
    failure ="{sudo}supervisorctl restart {group}", _raise=_raise)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 48, in run
    return exec_cmd(cmd, cwd=cwd or self.cwd, _raise=_raise)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 158, in exec_cmd
    raise CommandFailedError(cmd) from subprocess.CalledProcessError(return_code, cmd)
bench.exceptions.CommandFailedError: sudo supervisorctl restart frappe-bench-web:

INFO: A newer version of bench is available: 5.16.4 → 5.19.0

I am seeing this error since last week while trying to do bench restart --web --supervisor

Can someone give me some pointers on how to resolve this?

In terminal enter below command to edit supervisor.conf

sudo nano /etc/supervisor/supervisord.conf

Below [unix_http_server] enter this


sve and close the file

after that restart supervisor with below command

sudo service supervisor restart

in your bench folder run command

bench setup supervisor
1 Like

@mohitchechani Tried this, but same error. Modified it like this:


post the log of node-socketio.error.log

Please correct


1 Like