Error while installation on Fresh Ubuntu 18.04 Fresh Install

apt-get update && apt-get upgrade -y

apt-get install build-essential python-minimal python-setuptools -y

curl -sL | sudo -E bash -

apt-get install -y nodejs

sudo apt-get update && sudo apt-get install yarn

cd /opt


python --develop --site [domain] --user bench --bench-name erpnext --verbose

After the above-mentioned command at the very last step I am getting this error.

Used easy script with no success on Ubuntu 18.04 System, Tried 5 to 6 times. Same error with bench every time.

I have installed just 10 days back in another VPS. It installed perfectly. But since 3 days I am facing this issue.

**raise CalledProcessError(retcode, cmd) **
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=bench’]’ returned non-zero exit status 2

Follow below process:

sudo apt-get update && upgrade
Rebooted server

sudo apt-get install python3-setuptools python3-minimal redis-server build-essential

created user erpnextuser
sudo adduser erpnextuser (Adding a new user to erpnext)
sudo usermod -aG sudo erpnextuser (giving proper permission)
su erpnextuser (login as erpnext user)


Sudo -H python3 --production --site --user erpnextuser

This will install the ERPNEXT. After this I have updated the bench by running below command:

cd frappe bench/
bench update

Remove and reinstall redis server.

1 Like

Hello @Tufan_Kaynak2,
I’m battling with this same error on my localhost server, and I have tried your method. When I tried it, rendered a “frappe.exceptions.LinkValidationError: Could not find Default Currency: INR”

If you have ever come across this issue and have resolved it, can you share the method you used in correcting this error?

Thank you very much.

Exactly at which stage in which environment and which step did you get this?

during new-site, redis not ready, connect redis is error!

Everything Redis related, enable IPv6 by giving it “enable_ipv6”.

Redis fails to configure itself when there’s IPv6 available from the host, but not enabled it seems. When there’s no IPv6 available from the host, it works just fine in my case.

@iMoshi where do I give it “enable_ipv6” on ubuntu or on the bench?

@Tufan_Kaynak2 at the stage when it is creating a new site on a fresh installation. It gives this error;

“redis.exceptions.ConnectionError: Error 111 connecting to localhost:11000. Connection refused”. And if I run it again, it gives this other error;
“frappe.exceptions.LinkValidationError: Could not find Default Currency: INR”.

Also, if I still run the “sudo python --production --user [frappe-user]” it will install successfully, but not completely. That is to say that the login page cannot be found, and I won’t be able to login.

Thanks for your contribution in resolving this. I had to reformat the server and re-run the whole package, If I encounter the same problem, I would do well to post it right here.

Give me a +1 for this bug report.
I submitted a bug request for this. Please submit your comments and +1 there.

hey is it resolved…? i am facing almost same problem.can you help me in that?

where to write “enable_ipv6” , in which file?