Error while installation


I am trying to install erpnext through the shell script but when executing the same i am getting the following error

Adding debian mariadb repo
Installing packages for debian. This might take time…
Installing wkhtmltopdf
dpkg: considering removing wkhtmltopdf in favour of wkhtmltox …
dpkg: yes, will remove wkhtmltopdf in favour of wkhtmltox
(Reading database … 37229 files and directories currently installed.)
Unpacking wkhtmltox (from wkhtmltox- …
dpkg-deb (subprocess): cannot copy archive member from ‘wkhtmltox-’ to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess returned error exit status 2
dpkg: error processing wkhtmltox- (–install):
cannot copy extracted data for ‘./usr/local/lib/’ to ‘/usr/local/lib/’: unexpected end of file or stream
Errors were encountered while processing:

has anybody any idea about this…!!!

Seems like a network issue (the deb didn’t download correctly)

thank you for the response i’ll try the installation again !! :relaxed:


i am trying to add custom fields for item document but am getting this error

Duplicate Name Custom Filed Item-Category
Another transaction is blocking this one.Please try again in a few seconds.

i have tried it after few minutes bu i am getting the same error again and again.

Seems like a thread has gone to sleep. Login to mysql via bench mysql and kill the thread. To find which one run: SHOW PROCESSLIST