Error while installing Frappe/Bench [SOLVED]

I am facing problem while installing Frappe/bench in my system following easy installation process. This is the installation log-

Installing for Ubuntu vivid amd64
In case you encounter an error, you can post on

Adding ubuntu mariadb repo
Installing packages for Ubuntu. This might take time...
Installing wkhtmltopdf
Installing wkhtmltox package for trusty (Ubuntu 14.4) even if you are using vivid.--2015-11-10 09:31:47--
Resolving (
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-11-10 09:31:48 ERROR 404: Not Found.

My OS is- Ubuntu 15.04 \n \l

How can i solve this problem?

Thanks for reporting. Will fix and update you soon.

Welcome. Waiting for your update.

Looks like the issue is from the script trying to install a wkhtmltox release for vivid but a release for vivid doesn’t exist. The scrip says that its downloading the package for trusty yet it tires to grab one for vivid. Let me know if you want me to fix this with a pull request.

Fixed. Please check and let us know.

@saurabh6790 Sorry for late reply (Installation was taking some time). There is a new problem. I have tried to install 3 times but still getting some (same) errors. Here is the log-

Installing for Ubuntu vivid amd64
In case you encounter an error, you can post on

Adding ubuntu mariadb repo
Hit vivid InRelease
Hit vivid-security InRelease
Hit vivid/main amd64 Packages
Hit vivid/main i386 Packages
Ign vivid/main Translation-en_US
Ign vivid/main Translation-en
Hit vivid InRelease
Hit vivid-updates InRelease
Hit vivid-backports InRelease
Hit vivid/main Sources
Hit vivid/universe Sources
Get:1 vivid/restricted amd64 Packages [15.4 kB]
Hit vivid-security/main Sources
Get:2 vivid/multiverse amd64 Packages [134 kB]
Hit vivid-security/restricted Sources
Hit vivid-security/universe Sources
Hit vivid-security/multiverse Sources
Hit vivid-security/main amd64 Packages
Hit vivid-security/restricted amd64 Packages
Get:3 vivid/main i386 Packages [1,361 kB]
Hit vivid-security/universe amd64 Packages
Hit vivid-security/multiverse amd64 Packages
Hit vivid-security/main i386 Packages
Hit vivid-security/restricted i386 Packages
Hit vivid-security/universe i386 Packages
Hit vivid-security/multiverse i386 Packages
Hit vivid-security/main Translation-en
Hit vivid-security/multiverse Translation-en
Hit vivid-security/restricted Translation-en
Hit vivid-security/universe Translation-en
Get:4 vivid/universe i386 Packages [6,486 kB]
Get:5 vivid/multiverse i386 Packages [134 kB]
Get:6 vivid/main Translation-en [793 kB]
Get:7 vivid/multiverse Translation-en [103 kB]
Get:8 vivid/restricted Translation-en [4,228 B]
Get:9 vivid/universe Translation-en [4,456 kB]
Get:10 vivid-updates/main Sources [103 kB]
Get:11 vivid-updates/restricted Sources [3,687 B]
Get:12 vivid-updates/universe Sources [44.8 kB]
Get:13 vivid-updates/multiverse Sources [1,957 B]
Get:14 vivid-updates/main amd64 Packages [247 kB]
Get:15 vivid-updates/restricted amd64 Packages [13.1 kB]
Get:16 vivid-updates/universe amd64 Packages [122 kB]
Get:17 vivid-updates/multiverse amd64 Packages [5,195 B]
Get:18 vivid-updates/main i386 Packages [244 kB]
Get:19 vivid-updates/restricted i386 Packages [12.8 kB]
Get:20 vivid-updates/universe i386 Packages [123 kB]
Get:21 vivid-updates/multiverse i386 Packages [5,394 B]
Get:22 vivid-updates/main Translation-en [119 kB]
Get:23 vivid-updates/multiverse Translation-en [2,246 B]
Get:24 vivid-updates/restricted Translation-en [2,969 B]
Get:25 vivid-updates/universe Translation-en [71.3 kB]
Hit vivid-backports/main Sources
Hit vivid-backports/restricted Sources
Hit vivid-backports/multiverse Sources
Hit vivid-backports/main amd64 Packages
Hit vivid-backports/restricted amd64 Packages
Hit vivid-backports/multiverse amd64 Packages
Hit vivid-backports/main i386 Packages
Hit vivid-backports/restricted i386 Packages
Hit vivid-backports/multiverse i386 Packages
Hit vivid-backports/main Translation-en
Hit vivid-backports/multiverse Translation-en
Hit vivid-backports/restricted Translation-en
Hit vivid/restricted Sources
Hit vivid/multiverse Sources
Hit vivid/main amd64 Packages
Hit vivid/universe amd64 Packages
Hit vivid/restricted i386 Packages
Hit vivid-backports/universe Sources
Hit vivid-backports/universe amd64 Packages
Hit vivid-backports/universe i386 Packages
Hit vivid-backports/universe Translation-en
Fetched 9,414 kB in 4min 50s (32.4 kB/s)
W: Failed to fetch  Hash Sum mismatch

W: Failed to fetch  Hash Sum mismatch

W: Failed to fetch  Hash Sum mismatch

W: Failed to fetch  Hash Sum mismatch

W: Failed to fetch  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

Is it due to slow connections ? or for other reasons?

Sorry this is was my bad. You can install trusty wkhtmltox deb on vivid just fine, i tried to fix the install script, but there was a bug that just got fixed:

OK. At last, a few moments ago, installation process has completed successfully.

My problem is solved now. Thanks everyone for responding.