Error with switch-to-branch v8.x.x can not update --patch

Hi All

I have error use command

switch-to-branch v8.x.x.

I can not use command:

bench version 
bench update --patch

Could you help me? When run switch-to-branch v8.x.x, I need to do What step, Or can show me step by step how to update to use version 8. thanks.


Can you run bench setup requirements prior to running the update patch command and see if that works.

1 Like

Thank your suggestion, I run your command I have error.

Command "python egg_info" failed with error code 1 in /tmp/pip-build-Hu oDg2/mysqlclient/

You have suggest to fix this error or something, thank you very much


SNIMissing warning error can be fixed through ./env/bin/pip install 'requests[security]' and just to be on the safe side also try this ./env/bin/pip install --upgrade setuptools , then try running requirements command again to see if its fixed.

The switch-to-branch won’t work well if you are coming from version 9 or greater. The command will be deprecated soon.

To best way to stay on a particular version is:

cd ~/frappe-bench/apps/frappe
git checkout v8.x.x

cd ~/frappe-bench/apps/erpnext
git checkout v8.x.x

cd ~/frappe-bench
bench --site sitename reinstall

This will wipe your database so be careful.

Thank you very much, This way I try but I have same error, I think I need to find the solution for

Command "python egg_info" failed with error code 1 in /tmp/pip-build-Hu oDg2/mysqlclient/

Thank you very much, I try your way bu t I have another error, i think I need to find another way to update old version,

Hi All

now I can install old version v8.x.x

I need to reinstall ubuntu because have many error on my server.
Then I need to use manual install frappe use bench version v3.x.

#install bench version v3.x
git clone bench-repo
git checkout v3.x
pip install -e bench-repo

#init frappe v.8.x.x
bench init frappe-bench --frappe-branch v8.x.x