Errors in Installing ERPNext


I have installed ERPNext multiple times on different machines without any problems. But about a week ago I wanted to install ERPNext again, and this time I got this error message after running sudo python --production:

TASK [locale : Check current locale] ********************************************************************************************************************************************************************************************************
task path: /tmp/.bench/playbooks/prerequisites/roles/locale/tasks/main.yml:2
Using module file /usr/local/lib/python2.7/dist-packages/ansible/modules/commands/
<> EXEC /bin/sh -c ‘echo ~ && sleep 0’
<> EXEC /bin/sh -c ‘( umask 77 && mkdir -p “echo /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769” && echo ansible-tmp-1510068702.56-196144660405769=“echo /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769” ) && sleep 0’
<> PUT /tmp/tmpHMAH6g TO /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769/
<> EXEC /bin/sh -c ‘chmod u+x /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769/ /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769/ && sleep 0’
<> EXEC /bin/sh -c ‘/usr/bin/python /root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769/; rm -rf “/root/.ansible/tmp/ansible-tmp-1510068702.56-196144660405769/” > /dev/null 2>&1 && sleep 0’
fatal: [localhost]: FAILED! => {
“changed”: true,
“cmd”: “localectl”,
“delta”: “0:00:00.052409”,
“end”: “2017-11-07 15:31:42.927985”,
“failed”: true,
“invocation”: {
“module_args”: {
“_raw_params”: “localectl”,
“_uses_shell”: true,
“chdir”: null,
“creates”: null,
“executable”: null,
“removes”: null,
“warn”: true
“rc”: 1,
“start”: “2017-11-07 15:31:42.875576”,
“stderr”: “Could not get properties: Connection timed out”,
“stderr_lines”: [
“Could not get properties: Connection timed out”
“stdout”: “”,
“stdout_lines”: []
to retry, use: --limit @/tmp/.bench/playbooks/production/install.retry

PLAY RECAP **********************************************************************************************************************************************************************************************************************************
localhost : ok=5 changed=0 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 388, in
File “”, line 114, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 326, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘production/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘-vvvv’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

Can some help us with explaining what this error is and how we can fix it?


I think you are logged in as root. If that is the case use python --production --user frappe instead


Thank you for your reply. I am not logged as root and even when I did, I got the same error message.


I found out the problem but was not able to fix it.

the problem is with the command localectl as it just times out.

frappe@Server:~$ localectl
Could not get properties: Connection timed out

Has anyone seen something like this before?


I experience the same issue with scaleway but switched to linode problem solved i think its related to processor architecture and the system.


Thank you for sharing your experience.

I have installed CentOS instead of Ubuntu and now ERPNext is installed.

For what it’s worth… an non-zero exit status normally implies that a process couldn’t be reached. For ubuntu+locale (tune to suit your locale)…
sudo locale-gen
sudo localectl set-locale LANG=en_ZA.utf8
should fix it

grep -v '^#' /etc/locale.gen
will tell you which locale’s are present