ESS User Can not Print

Hi All,

Can ESS User not be given print right? I selected print option for the doc in the role permission setting but still ESS User gets this error.

Using the “Role Permissions Manager” you should be able to chek the “Print” box for any user role to help solve your problem.

You can also create new “Roles” if there is not sufficient permissions catagories or roles to suit your needs.


Already did that as mentioned in initial post. But still users assigned ESS role can not print.

Okay… I have seen something like this before in older versions of ERPNext where Role Permissions overrule each other in the wrong hierarchy order.

In your case, to test this, try unchecking the “Employee” role in the user profile and only check the “Employee Self Service” (ESS) role instead. Save the record and then use the “reload” function to push the change to the user.

Back in versions 10 and 11 I ran into this with Stock User and Stock Manager. If both roles were checked, the Stock User role would be used to control permissions for a doc instead of the more robust Stock Manager role. This would happen only if both roles were checked in the profile.

You might be running into a similar situation. It is certainly worth a try.

Hope this hleps…


Would be best to raise a Github Issue for this.

I see that ESS users are being given different permissions but not print:

The option needs to be made available here along with the option to customize the permissions.

Alternatively, you can just offer employees the regular Employee role and manage the permissions via role permission manager.

Yes, thanks…created a Github issue below

for now i guess will have to control with Employee otherwise don’t see any other option … tried everything else.

found the issue:
posting solution here in case anyone else comes across same problem.

Go to Permission for Page and Reports.
Select Page
Select Print and print format builder
select users for which you want print permissions including ESS for both the above pages.