Exchange Rate Read-only in Payment Entry

Dear All,

I’m facing Exchange Rate Read-only in Payment Entry, since update version 9.2.
Any issue like this?


Go to Account Settings and check “Allow Stale Rates”

1 Like

Hi tun,

I’ve tried, when checked, there is error message exchage not found, add rate manually.
When remove checked, there is no error message, but still dimmed read only.
Any more idea ? I’m wondering version 9.2 change default permission for exchange rate, i’m finding the cause.

Have a look at this:

The “Allow Stale Rates” setting was introduced for users who want to have a control on exchange rates used for transactions. If it is unchecked, the exchange rate field will be disabled.

Hi tun,

Yes I quite know about ‘Allow Stale Rates’, but i’m now facing read-only exchange rate after updated to version 9.2.
I’ve tried unchecked, check this ‘Allow Stale Rates’, Reload, log out / log in, server restart, and even try clear browser’s cookies. no way solved.
I’m quite sure some bug in new version.

This issue solved in #11409 Release 9.2.4

Hello @tundebabzy Tunde and @TTA TTA.

I can’t get him to let me make payments in any currency other than the default currency without the currency change.

With or without the check mark “Allow Stale Exchange Rate” you keep asking me for currency exchange.

I’m using version v10.0.21.

Any idea what might be going on?

are you sure the currency exchange is set?

Hi Tunde, thank you for responding.

I just don’t want to use the currency exchange, I want to use what is mentioned in this post.

My local currency is ARS for example, but this invoice was made in USD, the current account is in USD, and I am paid in USD, at no time do I need the conversion.

And by using “Allow Stale Rates” he keeps asking me to convert.


Please report this on github with information on how to reproduce this. This must be a bug