Exit status 1 line 147 of Easy install | EASY INSTALL ERROR!

Hello, i have been getting this error on UBUNTU 18.04 LTS fresh install,
Please provide some solutions i tried installing setuptools, cryptography and ansible and did install them successfully but still i am getting this error.

Any suggestions are welcome, Its URGENT.


Logs are saved under /tmp/logs/easy-install__2021-02-15__09-18.log
Checking System Compatibility...
ubuntu 18 is compatible!
curl already installed!
wget already installed!
git already installed!
pip3 already installed!
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-p7z700on/cryptography/
Traceback (most recent call last):
  File "install.py", line 436, in <module>
  File "install.py", line 143, in install_prerequisites
    'python3': "sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip"
  File "install.py", line 118, in run_os_command
    returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
  File "/usr/lib/python3.6/subprocess.py", line 311, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip' returned non-zero exit status 1.

Same error. No solution yet.

sudo python3 -m pip install --upgrade pip

this should resolve

1 Like

That was the eventual fix I also got. Thanks.

1 Like