Fail to finish setup wizard

I install on local Mac desktop.
Bench init worked well. ERPNext was installed well.
But when trying to finish setup wizard it stops and I got these on the terminal:

00:33:56 web.1            |  * Detected change in '/Users/rio/puniadev/punia-bench/apps/erpnext/erpnext/domains/__pycache__/services.cpython-37.pyc', reloading
00:33:56 worker_default.1 | objc[79231]: +[__NSPlaceholderDate initialize] may have been in progress in another thread when fork() was called. We cannot safely call it or ignore it in the fork() child process. Crashing instead. Set a breakpoint on objc_initializeAfterForkError to debug.
00:33:56 worker_default.1 | 00:33:56 Moving job to 'failed' queue (work-horse terminated unexpectedly; waitpid returned 6)
00:33:56 web.1            |  * Restarting with fsevents reloader

The * Detected change in... keep showing up but for different .pyc files everytime.

And sometime there is also occur this:

00:57:13 schedule.1       | <class 'pymysql.err.OperationalError'> Failed to enqueue events for site: site1.local

and this

01:06:24 web.1            | - - [08/Aug/2020 01:06:24] "POST /api/method/ HTTP/1.1" 200 -

Trying by clicking Retry button several times still always failed.

What is the meaning of these lines and how to resolve it so the setup wizard can be completed?

Thank you

May I know how you resolve this issue. Because I’m getting the same error

I didn’t resolve anything. I reinstalled from beginning and somehow the issue gone :smiley:
I think it has to do with the ownership or permission of the directory. Maybe you can check your bench and the hierarcy up and down.
Sorry can’t help much.

Incase you’re getting the error on MacOS, here’s a workaround:

1 Like