Failed to upgrade to 11.1.30

INFO:bench.utils:updating bench
INFO:bench.utils:git pull
Already up-to-date.
INFO:bench.utils:./env/bin/pip install Pillow
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Ple ase upgrade your Python as Python 2.7 won’t be maintained after that date. A fut ure version of pip will drop support for Python 2.7.
Requirement already satisfied: Pillow in ./env/lib/python2.7/site-packages (5.3. 0) frappe
INFO:bench.utils:git pull upstream master
From GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript

  • branch master → FETCH_HEAD
    Already up-to-date.
    INFO:bench.utils:find . -name “*.pyc” -delete frappe_io
    INFO:bench.utils:git pull upstream master
    From GitHub - frappe/frappe_io: Website for Frappe
  • branch master → FETCH_HEAD
    Already up-to-date.
    INFO:bench.utils:find . -name “*.pyc” -delete erpnext
    INFO:bench.utils:git pull upstream master
    remote: Enumerating objects: 289, done.
    remote: Counting objects: 100% (270/270), done.
    remote: Compressing objects: 100% (40/40), done.
    remote: Total 97 (delta 86), reused 67 (delta 57), pack-reused 0
    error: insufficient permission for adding an object to repository database .git/ objects
    fatal: failed to write object
    fatal: unpack-objects failed
    Traceback (most recent call last):
    File “/usr/local/bin/bench”, line 11, in
    load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
    File “/home/frappe/.bench/bench/”, line 40, in cli
    File “/usr/local/lib/python2.7/dist-packages/click/”, line 764, in ca ll
    return self.main(*args, **kwargs)
    File “/usr/local/lib/python2.7/dist-packages/click/”, line 717, in main
    rv = self.invoke(ctx)
    File “/usr/local/lib/python2.7/dist-packages/click/”, line 1137, in inv oke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/usr/local/lib/python2.7/dist-packages/click/”, line 956, in invo ke
    return ctx.invoke(self.callback, **ctx.params)
    File “/usr/local/lib/python2.7/dist-packages/click/”, line 555, in invo ke
    return callback(*args, **kwargs)
    File “/home/frappe/.bench/bench/commands/”, line 60, in update
    _update(pull, patch, build, bench, auto, restart_supervisor, restart_systemd , requirements, no_backup, force=force, reset=reset)
    File “/home/frappe/.bench/bench/commands/”, line 73, in _update
    pull_all_apps(bench_path=bench_path, reset=reset)
    File “/home/frappe/.bench/bench/”, line 249, in pull_all_apps
    remote=remote, branch=get_current_branch(app, bench_path=bench_path)), cwd=a pp_dir)
    File “/home/frappe/.bench/bench/”, line 159, in exec_cmd
    raise CommandFailedError(cmd)
    bench.utils.CommandFailedError: git pull upstream master

You have permission problems in your repo folder…

1 Like

Always did the upgrade the same way. go to frappe-bench folder and do a bench update. Always worked. I upgraded last week to 11.1.29 and 11.1.30 failed.

I have update to 11.1.30 without any issue in 5 different installations.
It could happened that you updated with sudo by mistake

Can you share the result of:
ls -l ~/frappe-bench/apps

ls -la ~/frappe-bench/apps/erpnext

ls -la ~/frappe-bench/apps/frappe

Owner of all the files listed is frappe / frappe.
Error seems to be located in the .git/ objects but all folders are set to frappe frappe with rwxr premission

Your issue has been solved?

no. Same issue

It worked without any issues on 11.1.31.