Failed Update to Frappe/ERPNext on Develop Branches

Tried to update my various Frappe apps last night (bench update --reset) and ran in to the following error.

Can any one suggest a fix?


Compressing objects: 100% (131163/131163), done.
error: bad packed object CRC for 69b31d6ed3a276a50405269a76b5259c17a2df47
error: bad packed object CRC for 69b31d6ed3a276a50405269a76b5259c17a2df47
fatal: packed object 69b31d6ed3a276a50405269a76b5259c17a2df47 (stored in .git/objects/pack/pack-761dd001574fd1952fdb9fe61641350bb9bd10b5.pack) is corrupt
fatal: failed to run repack
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 8, in <module>
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 127, in cli
  File "/usr/lib/python3/dist-packages/click/", line 1128, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/click/", line 1053, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python3/dist-packages/click/", line 1659, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python3/dist-packages/click/", line 1395, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python3/dist-packages/click/", line 754, in invoke
    return __callback(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/commands/", line 59, in update
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 436, in update
    pull_apps(apps=apps, bench_path=bench_path, reset=reset)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 661, in pull_apps"git gc --prune=all", cwd=app_dir)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 48, in run
    return exec_cmd(cmd, cwd=cwd or self.cwd, _raise=_raise)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 158, in exec_cmd
    raise CommandFailedError

Possibly a git issue. Navigate to your frappe folder/apps and in each of the app folders try git status and git pull to see if one of the apps is causing the issue. A web search of the error messages might suggest some fixes.

Thanks @smino, I tried as you suggested but all apps were good according to git.

Tried a few other things like python reinstall but my system went unstable and lost Xorg window system. So may have been another issue.

Rebuilding laptop and reinstalling frappe-bench shortly (got backups off beforehand), what a start to a week :laughing:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.