Field "route" is mandatory for Web Views

This is for anyone who cant figure this out. If you put something in this required space it always comes up with an error that shows Field “route” is mandatory for Web Views. What is the process to fix this.

Can you record a gif of what is happening? And for which doctype is this occurring?

This is any custom doctype that people create. When you click on the “web View” option. You have to type in the published field as well as the the route. This is more of a general question for anyone to create a custom doctype webview.

This is a validation message for DocTypes which have WebViews. You have to have a field with the fieldname as route for it to work

2 Likes

Please post a screenshot of the error and/or the traceback

Hi all,

this is the screenshot:

Steps to reproduce:

  • create a new custom DocType
  • enable “Has Web View”
  • add a route
  • try to save

This is indeed strange…

Resolution (thanks to @netchampfaris):

  • add a field called Route:
    grafik
  • save and it works

The field “route” will be visible on each instance of the DocType and allow to set an individual route…

2 Likes

I found the same issue. I read from tutorial that webview is underconstruction.