Fields created in customize form does not display in UI

New fields created are not displaying in UI. Not sure what i am missing.
Erpnext v13
Here are the screenshot

What are the properties of the fields (click on Edit for the resp. field)?
Not sure if this is the reason but it could be that some of the options are set wrong so they don’t show up on the UI (e.g. hidden checked, Permission level not appropriate etc.)

please avoid using scan_barcode field name as it is the special field handled for scan feature.

@bluesky Thank you for reply.

Thank you for the suggestion but I also added “Test1” field that too is not visible on UI.

my test on v13 is Okay

please refresh browser in Customize form for Stock Reconciliation to make sure your customization updated/saved ok.

Same here. I reproduced with your settings and it works for me as well.

@bluesky @szufisher
Sorry for not clearing things. It is showing when we create new stock reconciliation but it is not showing in already created stock reconciliation (before adding test1 field).

because for existing document, if field value is null(none) , system will will auto hide the field.
if your stock reconciliation document is already submitted, and you would like to edit the new field after submit, please tick Allow On Submit

@bluesky @szufisher
Now it is showing on already submitted document.
Thank you. Really appreciate your help.