File too big. File size exceeded the maximum allowed size of 25 MB


Screenshot from 2024-05-21 16-04-46

When I am updating the Serial and Batch bundle through a CSV file, the Table is updated but not able to save as it throws the error.

The file size is 110 kb and it throws the error in any attachment.

If I update the system settings in Max File Size (MB) to 100 MB, then it throws the error “File size exceeded the maximum allowed size of 100 MB”. The same goes for the max_file_size.

Hii @Foram
In the site_config.json file, add the following:

"max_file_size": 52428800,

where the number represents the maximum file size in bytes (equivalent to 50MB).
This setting applies to the whole site.
this solution should useful for the entire site.

I have already updated that and tried that, It throws the error.

Screenshot from 2024-05-21 17-00-37

Looks like an nginx issue. If you’re using docker, find the “CLIENT_MAX_BODY_SIZE” arg in the compose file and change it to 1000m (for 1000MB limit). Rebuild the container and it will be solved.

If not docker, then you’ll probably have to find that arg in the nginx.conf file, update the value and restart nginx.