Filezilla connection

I had previously used file zilla to get access to json file
now after update of both filezilla and erpnext, iam not able to get filezilla connected
i have tried these
protocol : sftp
host : ip address
username : frappe
password : frappe
port : i have used all these…8080, 3022, 21, 22
iam getting this error

Error: Server unexpectedly closed network connection
Error: Could not connect to server

any help on this please
iam trying to point my domain name and i need to edit the json file
iam on windows with vm

Check that the sshd is running on the machine.
Login as frappe in the terminal and run

sudo netstat -tnlp | grep -i “22|ssh”

You should see something like this… (the 582 may be different)

tcp 0 0* LISTEN 582/sshd
tcp6 0 0 :::22 :::* LISTEN 582/sshd

If not, then you need to restart the service

sudo systemctl restart sshd

Hi trentmu
i ran sudo netstat -tnlp | grep -i “22|ssh”
it didnt throw up any thing
then, i ran sudo systemctl restart sshd
it gives an error
sudo: systemctl : command not found

i tried this method

seems ssh is running

OK, I didn’t realise that you are using the VM - sorry. The port on that is 3022

Hi trentmu
tried with all below listed ports… but it doesn’t throw up any results
netstat -tnlp | grep -i “22|ssh”
anything that i am missing
its pretty urgent
Thanks Again

did a filezilla network connection test
it gives me this error
Response: 200 OK
Failed to create listen socket on port 0, aborting.
Connection closed

this error is faced when you use an older version of filezilla , please recheck if your filezilla is updated properly ,else try upgrading to the latest version, thanks.

else check for mistake in configuring fixed IP address.

thanks bharat_suthar
i just uninstalled filezillaa… downloaded the latest version
iam still getting the same “socket not listening” error when i run network test in filezilla
Thanks again

Port 3022 won’t show as a listening port, but is configured as a NAT map in the production.ova.
You can test this with something like PuTTY or a SSH terminal app. Create an SSH connection to localhost:3022 in PuTTY, or just use

ssh frappe@localhost -p 3022

i have hit a wall
any other way to get this resolved
please help

added port forwarding in my vm box
3022 to 22
and filezilla could connect
when i ifconfig the vm, the inet addr is
when i try to ping in windows , it shows request timeout
any pointers on this
thanks and regards

may be:

ssh -p 3022 frappe@

hope this helps