Fiscal Year - Naming Series Problem v14.31.3

Hello Friends,

I have installed ERPNEXT on a fresh UBUNTU 22.04 LTS server running on Hyper-V of Windows Server2012 r2. I got ERPNEXT v14.31.3 on my server.

After complete installation, I set the fiscal year 2023-24 and customized the naming series of Purchase order to PO.FY.### which should generate a naming series of PO2023-24001 but it generates POFY001.

All other naming options i.e. YY, MM, YYYY etc works fine.:

But as soon as I put .FY. in Naming series, it throws an error:

The similar behavior was observed on naming series of Sales Order, Quotation, RFQ, Supplier Quotation etc.

I believe that it is bug carried forward from v14.31.2 because before that it was working fine.

Can anyone help me on fixing this issue?


It worked on the latest version of erpnext version 14.

Please check it.

Thank You!

Many Thanks for your kind and quick response. It is not working on my installation. I am not a software person, hence I am unable to figure out the problem.


can you suggest a solution to my situation, please? had I done something wrong?

If manually installed erpnext then update the version using the command.

Please first take a backup then after apply the commnad.

bench update

// OR 

bench update --reset

Thank You!


Thanks again for your quick support. I have updated the bench using both the methods. it updates successfully and I am on ERPNEXT v14.31.3, I have tried to update the bench many times without any good luck to remove this error.

While installing fresh, I used “nvm isntall 20” instead of “nvm install 16.50” for npm. can it be a problem? shall i switch back to nvm 16.50?

Moreover, I am running UBUNTU 22.04 (Fresh Installation) on Hyper-v at Windows Server 2012 r2. I have assigned 8GB ram and 1TB storage to the Hyper -V machine on which the ERPNEXT is installed.

I am not able to identify any other deviation from installation guide and my setup.

your help will be highly appreciable.

Hello Friends,

Following the above discussion, I have created a fresh virtual Machine with Ubuntu Server 22.04 LTS server and installed the ERPENXT14 on it.

Upon first time setup, I re-confirm that there is a serious problem with the Fiscal Year Settings in v14.31.3 of ERPNEXT.

Here are the versions of all the installed apps:


  1. There is no option to set Fiscal Year as Default:

  2. Fiscal Year ".FY. " is no more working in Naming Series.

can anyone please help???

When fiscal year is default then that button not showing.

Hi @mohsininspire

Thanks for your response!

I haven’t set fiscal year as default as I didn’t get any option to do so.

I have created a fresh VM and installed everything from scratch. Can you suggest a workaround for this problem?

When you do setup wizard at that time automatically created based on your financial year.

Hi @mohsininspire

Sorry to bother you rapidly. but at the setup wizard, financial year is not asked if you are installing v14.31.3 on a fresh server.

I have installed this server 3rd time today.

am I doing something wrong?


When you setup wizard, is it comes?


It comes but I get only 3 steps:

  1. Language
  2. Name
    3 Compnay and Bank

then it goes to complete setup.

In 3rd step, there is Financial Year.

Yes, I followed the installation as advised on this link:

can you advise any other guide to follow for fresh installation of ERPNEXT on UBUNTU 22.04 LTS server?

I found this installation guide very useful.