Forgot to set developmode to 1 andcreated doctypes

So, I created 5 doctypes without switching the develop mode to 1 and now in my apps I don’t have their files, while these doctypes are visible when I login via running the bench. I tried to some commands like "bench --site execute frappe.reload_doc(“your_app_name”, “doctype_name”, force=True)
" the it didn’t worked and now when I push to github there no new module is created. How to solve this?

First set developer mode on.

Then Go to that doctype you created. And Uncheck is custom check box, and save it.

After this you run: (not necessary)

bench migrate

The problem is i cant uncheck the custom buttom and even if i duplicate it while keeping the developer mode =1 , then in duplicate file i even cant uncheck custom.

When You open doctype or document , are you getting warning like Site currently is on developer mode?

And what duplicate file?


bench set-config developer_mode 1

Hi @Ujjwal_Bisaria1:

The right key is developer_mode (note the underscore).

Are you logged in using Administrator user?

Hope this helps.

yes when I open the doctype a warning is coming there, the same you mentioned,

and when I uncheck the custom option then while saving the error comes as “Standard Doctype cannot have default print format, use Customize Form” and hench I am not able to uncheck it.

about the duplicate, i read a post where one person mentioned while keeping the developer mode to 1, duplicate the doctype and then uncheck the custom option, but that too isnt wokring.

and I am logged in as administrator also.

yes i am, and using the same command , but issue isnt resolved.

If possible share trace back and gif/video


I have attached a drive link in which a video is recorded with the problem.

Hi @Ujjwal_Bisaria1:

Check the View Settings on your docytpe …

Any print format there?

yes I have, is that causing the issue?

Hi @Ujjwal_Bisaria1:

Yes … it’s the planned behavior

		if self.default_print_format and not self.custom:
			frappe.throw(_("Standard DocType cannot have default print format, use Customize Form"))

So what should i be doing?


Just delete it and use form customization on site … or maybe you would can add property setter and packing it with your custom app.

Actually I don’t know why is not allowed on doctype creation, but this restriction is there since 2017 … so it’s probably due a good reason.

Hope this helps.

hey @avc thanks you very much, it worked and I was able to push the doctypes to GitHub and templates also got created in my local machine.