Frappe-bench-frappe-web starts normally but unable to connect to the server with browser


I have installed erpnext and it is accessible via the browser when i run bench start.

but when i run it with the supervisor all workers starts normally and the log of supervisor also shows the same thing but to the surprise i was unable to access it via browser.

then i saw the log of the inbuilt webserver which is in frappe-bench/logs directory. This log also shows nothing and everything is normal.

i am using multitenancy DNS setup. but disabling the multitenancy setup also didnt help.

any help in debugging the issue is welcome.

fyi OS is centos7, and using nginx as proxy server and directly accessing the url.
and the host and site i created is


But the issue is that the is called on port 9000 even when i am running on the nginx webserver while on dns based multi tenant based setup. The socket info comes as site and port separately due to which the proxy setup breaks. Please fix this. use the exact address with updated ports to counter this issue i.e. sitename:9000 in the python script instead of {site: “sitename”, socket_port: 9000}

Another issue is the port does not gets updated in the nginx.conf when updated via bench.


If you have issue, share specific traces, otherwise its really hard to debug.

Hi Rushab,

The issue is that i have no logs and every thing in the logs is alright in Frappe-bench-frappe-web but i am not able to connect to the application with any proxy server neither nginx nor apache httpd. Note that the firewall is entirely disabled.
You are welcome if you can help me in collecting logs from the server. And as i previously stated it is working with bench start command.

But for the port you can see that in the html source of the /desk url just search for site name while in dns based multitenant configuration.

And for nginx.conf port update issue do let me know how to provide the logs.


Hi @vipin.jn.24,

what happens on

$ bench setup socketio
$ bench setup nginx
$ bench restart

Are you sure that all NodeJS-packages are installed correctly?

1 Like

Okh i got the issue.

Yarn was not installed and the frappe bench failed to install successfully which i ignored while installing.

So i did installed yarn via the method listed on yarn website and installed fresh copy and now the web service starts successfully via supervisor.

but i have 2-3 more issues let me create a new thread for them.