Frappe_docker with bench_manager preinstall

Hi guys,

I did a fresh production installation of Frappe and ERPNext today, using the frappe_docker image. I also have the bench_manager successfully installed but when using it to create new site as the subdomain. i always got the 404 not found message.
Do we have anything else to do in order to make the bench_manager works ?

Thank you guys alot

It turn out I didn’t config the traefik correctly, change it to listen to all the subdomain resolve this issue, but not new issue come out, when navigating to the new site I got the Internal error response, tracking the erpnet_python_1 container I see this exception:

Do you have any ideas ?

Check mysql.user in mariadb.

User host should be wildcard. If there is no wildcard host, add it.

For image building process GitHub - castlecraft/custom_frappe_docker

1 Like

thank you very much.

  • Image building process
    Yes, i’m using one similar to this right now
  • Check mysql.user in mariadb
    The user and database is automatically created by the bench_manager. So if i have to manually check it then the bench_manager is some how not usable ?
  • User host
    About the User Host, do you mean about the Mariadb Host ?
    I have tried %, * with frappe_docker but it return in error for unknown host :
    Can you help me pointing out what is wrong ?

Thank you very much again

MariaDB> grant all privileges on DATABASE_NAME.* TO 'USER_NAME'@'%' identified by 'PASSWORD';
1 Like

Thank you very much,
I have tried and the result is the same:

I’m using Bench_Manager right now, and tend to expose it to some certain user so that they can create site for client. If we have to run or manually config the site creation seem Bench_manager can be used in my case ?

I don’t think bench_manager may work in docker.

In the production image there is no bench command. Only the commands available in bench_helper are available in prod images

1 Like

I’ve never faced this issue.

1 Like

When call Bench help in erpnext_python container I see we have the new-site command

And seem bench_manager will invoke the console process and run that commad. In fact it seem the bench_manager has successfully create folder structure in Nginx container and Erpnext_python container too.
But it really weird that although the generated user has all it privileges but the exception complains about can not connect to DB still occurs :frowning:

I don’t know what’s happening with your machines.

I was able to start the site with bench manager.

I updated the custom_frappe_docker repo to add bench_manager.

It always works for me and
I can’t really help you because I am not facing any issue.

1 Like

thank you very much,

I can set up a site with bench manager and start it without any problems. But when using bench_manager of that site to create a new site, I face the issue above. :frowning:

So you can create new site with bench_manager and access it without any problems ?

I will try your custom_frappe_docker

Once again, thank you very much. :smiling_face_with_three_hearts: