Frappe Doctypes are not being created inside project directory

created docTypes are not being created inside doctypes folder in frappe , i have tried unchecking custom option and setting developer_mode to 1 but still nothing is helping.

Hy @Me-key-us

Try this command

bench stop
bench start
bench set-config -g developer_mode 1
bench migrate

I hope it’s working

Thank You!

1 Like

thank you but this doesn’t work neither.

Hy @Me-key-us

Try command

bench start
bench update --reset --no-backup
bench set-config -g developer_mode 1

Thank You

Hi @Me-key-us:

Are you logged in as administrator? (Not role,I mean user called “administrator”)

1 Like

Above already is a lot of good and correct advice.

Let me add one piece which I didn’t get out of the docs but from painful experience.

I ran into problems due to using “bench update --reset”.

The reason was that I didn’t take into account where my app’s repo lives.
Mine was the repo created when you do “bench new-app”.
It existed only inside the bench, at one place.

The “--reset” did kind of unbuild my app, which I imported onto another dev training computer after returning from instruction, and took it from there afterwards to build onto partial accomplished goals.
It took me quite some time to figure it out.

There are relevant warnings when doing this in the logs, but you need to have the background knowledge in order to understand what it’s doing to your apps.

The warning tells you if you really want to get an unshallowed copy of the frappe app which bench init installs.
But it doesn’t tell you that it also resets HEAD of the other apps to some default state.

In my case the default state was the initial commit, so I lost data. In others its the right thing to do, depending on how you use git and where your repos live – especially backup repos, etc.

I could recover it with some git data recovery, because in my case the data was still there (it could also have been garbage collected (gc in git command abbreviation parlance) via git automation or side effects, so I was just lucky).
The git documentation has the relevant information for data recovery in such a case, but not in the first chapters. You need to dig a bit to find it, but it’s still easy to find, has to do with “reflog”.

So I had a case of:

  • lack of knowledge
  • not heeding the warning enough (I heeded the “want a small frappe repo in the bench” part, the other was implied only, and I didn’t realize it until …)
  • because it was (kind of) one-sided
  • luck to get out of it
  • an excellent learning occasion out of a certain newbeeness
  • additional, but necessary learning, compared to the other instructing
  • costing precious time, making me run into deadline problems outside of the learning context (and inside, too).

Also, you might want a backup when using the reset option of bench update.

Building is a lot of work, so losing commits due to unintended onereponess can be costly, not only painful or annoying.

1 Like

yes I am logged in as adminstrator

anyway here is how i fixed it. so when creating a doctype we all know that we have to pick a module so when i go back and look at my module definition when defining my module i hadn’t selected an app name for it. so i selected an app name for that module next i went back to adding a doctype i entered the doctype name selected the module i just created with an app name, finally the doctype folder was created inside my project structure. sorry for bothering everyone.

1 Like