Frappe/ERPNext Theming Tool

This fixed it. It might be difficult to use though as one still has to figure out the class of each element in order to modify. Awesome app though.

1 Like

Try the browser inspect tool to get the class name it’s helpful.

solution for the error.

--drop column from sql
ALTER TABLE `tabModule Def` DROP COLUMN `custom`;
--run from frappe-bench
bench --site site1.local install-app theming_tool

Theming tool working fine.

@afarran3 : thanks for contribution.

1 Like

As much as I’d like to try this tool:

On downloading (attempt) I get the error:
FileNotFoundError: [Errno 2] No such file or directory: ‘./apps/theming_tool/’

I have the feeling this might be a permission issue, can you confirm - or do you maybe have another solution? Thank you.

EDIT: Additional info: I am trying this as user “frappe” inside the stock Ubuntu 18 production VM.

Can you post your steps and logs then point out where the error shows up?

Thank you for your reply. Of course I can, though it’s fairly simple:

  1. I log in as default user “frappe”
  2. I open up a terminal
  3. I do “cd frappe-bench”
  4. I enter the command(s) you posted in the first post up here (“bench get-app…” etc.)
  5. The last output line of this command is already the error I mentioned before.

Like I wrote before - it’s the stock Ubuntu VM, titled “ERPNext-Production-20200707093143” I am using. Also I did not alter anything in this image except setting up a static IP and then starting to adapt and playing around with ERPNext (from within, no external changes).

EDIT: Wait no, I installed the whole MATE Desktop train to have a GUI right on-machine. Though it’s no longer necessary because we are no longer testing on it directly, but from other PCs on the network.

Are you sure that you are passing commands from the bench folder? are all command work fine there?
please try the below command and share a screen shot.

frappe@myserve:~/erpnext$ bench version
erpnext 13.0.0-beta.9
frappe 13.0.0-beta.9

Certainly. Here comes:

This thread may help !!!

Oof. Like in the linked thread, the ownership was all correct on my system, and the chown didn’t change a thing nor help a bit :slightly_frowning_face:

EDIT: I don’t know where the hiccups came from, but just now I tried again and it worked. Could you please add to the very first post that you have to set developer mode first for the second command - the actual installation - to work? Thank you!

EDIT 2: Doing a really great job there, thanks a lot, @afarran3

1 Like

I just want to notice any one that want to use this tool, you should enable “developer_mode” first.

Thanks @mwrsa.

Before I kill my system by trying it out - is the Theming Tool compatible to the current V.13 of ERPNext?

Edit: Ok, let me poke @afarran3 :laughing: You out there? Have you tried it?


I have an error

An error occurred while installing theming_tool:
(‘Module Def’, ‘Theming Tool’, IntegrityError(1062, “Duplicate entry ‘Theming Tool’ for key ‘PRIMARY’”))

how I can solve it plz?

bench uninstall-app theming_tool --force

1 Like

I got error when I tried this " bench uninstall-app theming_tool --force "

FileNotFoundError: [Errno 2] No such file or directory:‘./’

Bench —site uninstall-app theming_tool —force

1 Like

Thank you for your help !

I installed theming tool but when I add my theme settings nothing happen!

also code for theme never change !

what’s the wrong !

1 Like

Yes it works just fine with V.13.

It will not work like this, you should not use the code field to add any CSS code (it will be enabled in V.2) instead you can use the table and other fields for adding your customization

Hi @afarran3 , does this work with V14? Have you tested it? I really like the concept and was thinking of experimenting on my V14 ERPNext.