Frappe-framework@: The engine "node" is incompatible with this module

Good Evening…

I am having an issue installing erpnext on ubuntu 22. The error I am getting when running " ```
bench init frappe-bench

error frappe-framework@: The engine "node" is incompatible with this module. Exp                                                                         ected version ">=14". Got "12.22.9"
error Found incompatible module.
info Visit for documentation about this                                                                          command.
Traceback (most recent call last):
  File "/usr/local/lib/python3.10/dist-packages/bench/commands/", line 68                                                                         , in init
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 105                                                                         , in wrapper_fn
    return fn(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 79,                                                                          in init
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 432, in get_                                                                         app
    app.install(verbose=verbose, skip_assets=skip_assets, restart_bench=restart_                                                                         bench)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 126                                                                         , in wrapper_fn
    return fn(*args, **kwargs)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 230, in inst                                                                         all
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 569, in inst                                                                         all_app"yarn install", cwd=app_path)
  File "/usr/local/lib/python3.10/dist-packages/bench/", line 47, in run
    return exec_cmd(cmd, cwd=cwd or self.cwd)
  File "/usr/local/lib/python3.10/dist-packages/bench/utils/", line 1                                                                         55, in exec_cmd
    raise CommandFailedError

Can anyone assist me in rectifying this error or giving me a link that will assist me in resolving the issue ?

You can try installing node v14 and run the command again

nvm install 14

** install Node.js 14.X package**

sudo apt install curl curl | bash
source ~/.profile

nvm install 14`

1 Like

I a getting the same error, and I have node V16.15.0 installed.

Any clues for a fix?

previously had node 12,
installed node 16

but bench is still using v12.

Run the following commands:

sudo npm cache clean -f
sudo npm install -g n
sudo n stable
sudo n latest


This one works

1 Like

Yes I can also verify, worked for me too

That was my problem! Thanks!

This helped me much.

Thank you very much for sharing the solution.