Frappe in Docker on Fedora

I am at a loss. I tried for sometime to get frappe in a Docker so i could work in this Docker and easily distribute it. I am working on fedora and got many problems. I tried to install Frappe but i always get error messages. So i wanted to ask if someone has a tutorial to install it on Fedora or maybe it is easier to make a Debian Docker container and install it in there?

If you use frappe/frappe_docker, it is based on official Python images based on Debian.
It is based on selected Python version provided officially, like normal installation on any distro it doesn’t require to build selected python version as part of image build.

Check the readme for production setup which is immutable containers and development setup where benches are created under volume for development.

Read the FAQ

It should work on any distribution that supports containers.

Podman should also work provided you get it to work with VS Code devcontainer for developement. Or use it without VS Code devcontainer for development.

If you wish to build your own images using fedora you can refer the source of frappe_docker and translate it to RedHat/Fedora commands. You may need to build python for compatible version.

Thanks for the quick reply, i tried to do it with frappe_docker, but it always gave me the error message:
ERROR: Missing mandatory value for “image” option interpolating frappe/erpnext:${ERPNEXT_VERSION:?No ERPNext version set} in service “configurator”: No ERPNext version set
So i thought i have to edit the code and searched but never found out where i have to change something.

Recently someone added a documentation for mac frappe_docker/docs/ at main · frappe/frappe_docker · GitHub

The PR that added the doc mentioned problems with environment variable. added guide for linux/mac to setup frappe docker by KMJ-007 · Pull Request #1149 · frappe/frappe_docker · GitHub ${ERPNEXT_VERSION} is environment variable from the .env file.

Figure out how to pass environment variables or hardcode them.

Thanks a lot it worked!