Frappe Installation on Mac OSX High Seirra (Issue with site creation)

Tried to install ErpNext on macOS High Sierra manuaally as the easy install script did not work at all for this version of macOS. Steps followed are …

  1. Install Xcode
  2. Installed Home-brew
  3. Installed git using brew install git
  4. Installed node using brew install node
  5. Installed redis using brew install redis
  6. Installed mariadb using brew install mariadb
  7. Started mariadb using mysql.server start
  8. Secured mariadb using mysql_secure_installation
  9. Installed virtualenvwrapper using pip install virtualenvwrapper
  10. Installed ipython using pip install ipython
  11. Installed cask using brew tap caskroom/cask
  12. Installed wkhtmltopdf using cask install Caskroom/cask/wkhtmltopdf
  13. Cleaned up brew using brew cleanup --force
  14. Cleaned up cask using brew cask cleanup
  15. Created bench-repo by git clone GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps bench-repo
  16. Installed bench-repo using sudo pip install -e bench-repo
  17. Initialised bench using bench init frappe-bench
  18. Edited /usr/local/etc/my.cnf with required content for site creation
  19. Stopped mariadb using mysql.server stop
  20. Started mariadb using mysql.server start
  21. Change directory to frappe-bench cd frappe-bench
  22. Started site creation using bench new-site site1.local

**Now this is running for last 3 hours and you can find the progress, very unusal as it takes minutes in Ubuntu16.04 /CentOS 7.4.

Detailed log file can be found here …

Please help !!**

Run bench start in one Terminal tab and try doing new-site on another tab.

1 Like

Also, if you’re successful please have it updated at The Hitchhiker’s Guide to Installing Frappé on Mac OS X

Hi Rushabh,
Thanks for your prompt reply, it worked !! BTW… could you let me know the logic behind, I mean to say the easy install does the same? I have never noticed bench was being start while creating default site site1.local.