Frappe localhost not working

I installed new frappe bench using bench init frappe-bench && cd frappe-bench

and installed app,site

but when i start using bench start

i get this error

The localhost page isn’t working

localhost didn’t send any data.

when i switch to terminal i see red on this line

but when i switch to another folder
which installed two week before i get the same on the terminal window

but localhost runnig and everything is fine

can anyone help me please

I am very new to ERPNext, but faced the same problem. It worked for me after running

$bench get-app erpnext GitHub - frappe/erpnext: Free and Open Source Enterprise Resource Planning (ERP)
$bench --site localhost install-app erpnext

worth giving it a try…

when i type
$bench --site localhost install-app erpnext

getting error no such site

so i tried

$bench --site mysitename install-app erpnext

then it installed

when i tried to run localhost

i am getting an same error

localhost didn’t send any data.

getting error no such site
I think you need to create the site first
bench new-site localhost

is it necessary that site name is localhost

Nope. I have tried installing it only once and had the same problem. So suggesting what working for me…


i tried to bench new-site

but i getting error

@spoojary i run bench start in other folder which i installed frappe 2 weeks before and i switched to browser and typed localhost:8000 i redirected to desk of frappe and everything i running fine but not in new folder which i installed today why?

Can you share a screenshot of what you get in your browser?

@rmehta i re installed the app so the error is gone and when i started localhost i getting only image of frappe in console of browser i getting error

desk:41 Uncaught SyntaxError: Unexpected token {

when i expand the link
`if(!window.frappe) window.frappe = {};

frappe.boot = {{ boot }};

frappe.csrf_token = "{{ csrf_token }}";`

{{boot }} is under lined red color


I am facing problems while installing ERPnext setup.
My erpnext version is 7.2.29 and Frappe version is 7.2.29

I have installed erpnext from master branch.

The following error is being displayed while installation :-

Please help.

Mohini Kulkarni