Frequent site timeout after maria db engine change

Hi we recently got a notification from AWS requesting us to upgrade our mariadb engine on our AWS RDS from 10.0
as 10.0 will be deprecated an no longer supported.

After the change was done. (from 10.0 to 10.3.20) we began noticing frequent timeouts to our all sites pointing to the remote RDS

The timeouts happen on the average every hour, the initial suspicion was a background job
but after disabling all background jobs we noticed the site timeouts are still happening.

Has anyone else experienced this?

What’s your new MariaDB version?

version 10.3.2

I’ve never experienced what you’re describing. And don’t have any notes about version 10.3 in my wiki. I’ve been running v10.4.6 for quite a long time.

Random Guesses
Without examining the database and logs, and trying to pinpoint a root cause, there are a few things you could blindly try.

  1. One is adjusting certain timeouts. See link below. It’s pretty easy to change them. Then see if there’s a noticeable difference. And if not, revert them back to previous values.

[MySQL, MariaDB: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.]

  1. Also, unless you really need it, I recommend disabling DNS lookups for MariaDB. You can modify your configuration as follows.

  2. If there is a particularly large query (perhaps running hourly?) then you might consider increasing the value of the max_allowed_packet variable. Default value is 1MB.

No guarantee any of these help, but it’s something to try, before you take a deep dive into MariaDB.

I have tried your suggestions,

Still get timeouts

Looking at the aws rds error log

i see this error intermittently

Aborted connection 158737 to db: ‘unconnected’ user: ‘rdsadmin’ host: ‘localhost’( Got an error writing communication packets)