Fresh manual install, first login, language prompt messed up

First time EPRNext user. I just installed using the Manual Install method described here: GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps. It took most of the afternoon to get underlying prereqs installed to levels acceptable to Frappe/Bench/ERPNext, but I finally got the server to start.

I pointed my browser to port 8000 and got the expected login page, and it accepted my Administrator credentials. After that, I get “Hello!” with a language prompt. However, my choices are “E”, “n”, “g”, “l”, “i”, “s”, and “h” (see attached image).

Selecting any one results in a window “Something went wrong” / “Server error: Please check your server logs or contact tech support.” In frappe.log, I see errors like the one below. But the message doesn’t tell me anything useful.

I’m running under Ubuntu 16.04. I see the same result with a local Firefox browser and a remote Edge browser.

Any ideas?

[ERROR] 2017-08-31 15:40:46,548 | /home/mdadmin/frappe-bench/apps/frappe/frappe/
Site: site1.local
Form Dict: {
“cmd”: “”,
“language”: “E”
Request Error
Traceback (most recent call last):
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 57, in application
response = frappe.handler.handle()
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 22, in handle
data = execute_cmd(cmd)
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 53, in execute_cmd
return, **frappe.form_dict)
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 923, in call
return fn(*args, **newargs)
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/desk/page/setup_wizard/”, line 170, in load_messages
m = get_dict(“page”, “setup-wizard”)
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 122, in get_dict
message_dict.update(get_dict_from_hooks(fortype, name))
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/”, line 140, in get_dict_from_hooks
File “/home/mdadmin/frappe-bench/apps/frappe/frappe/geo/”, line 38, in get_translated_dict
timezone_name = get_timezone_name(get_timezone(tz), locale=locale, width=‘short’)
File “/home/mdadmin/frappe-bench/env/local/lib/python2.7/site-packages/babel/”, line 644, in get_timezone_name
info = locale.time_zones.get(zone, {})
AttributeError: ‘NoneType’ object has no attribute ‘time_zones’
[ERROR] 2017-08-31 15:40:46,610 | /home/mdadmin/frappe-bench/apps/frappe/frappe/utils/
New Exception collected with id: 2017-08-31 15:40:46.549322-


@reyelts thanks for reporting. We will push a fix soon.

Thanks much.
Is there any kind of workaround?
If not, how will I know when the fix is available?


When did you last run a ‘bench update’

I had the identical problem and ran an update 2 days ago and problem solved…

As I said, it was a fresh install… so no updates applied. Kinda silly to constantly update/re-test hoping the problem magically goes away. That’s why I asked for an ETA or workaround.

“Kinda silly to constantly update/re-test hoping the problem magically goes away”

Not silly at all - fixes are committed routinely and typically are unannounced.

When you hit a snag wait a bit then run ‘bench update’ and often the magic happens!

To give you an idea of the fix rate Travis CI - Test and Deploy Your Code with Confidence

So thanks to your error report a hotfix deploy would have been a matter of hours.

Right, but I don’t really have time to constantly perform updates hoping to see if a fix is there. Plus, constant updates means introducing more opportunity for instability. I guess it’s just a different support philosophy than we’re used to.

Anyway, I did get an update performed and the configuration display error went away. However, once it came up, I had no ERPNext modules active… just the base framework stuff. Confusingly, bench reported ERPNext was there. I found a forum entry where someone else had the same symptoms and the recommended solution was bench reinstall. That failed in a blazing list of errors culminating “_mysql_exceptions.OperationalError: (2006, ‘MySQL server has gone away’)”.

So, I’ve come to the conclusion ERPNext simply isn’t ready for prime time.

Yes like any product it’s not for everybody, say a case of you get what you pay for, and of course competition is healthy!