Fresh Production Branch Installation ( v 10 ) - First Login - stuck on "Verifying"


After a fresh installation ( I used the Hitchhikers Guide ) and shifting to the production branch ( bench switch-to-master ) I set up a new site and served it. My first attempt to login with Administrator ID failed with the “Verifying” message in the login page .

The version of the applications are ERPNext ( 10.1.73 ) and Frappe ( 10.1.66 )

When I checked the server console there are no errors .

When I checked the JS Console also there are no errors.

When I looked and tried to debug the login page, it is coming to the line

	login.set_indicator("Verifying...", 'blue');

but does not get to the login_handlers method.

I had earlier tried with the default version ( development ) but it was giving me intermittent “Verifying” errors so I built a new instance with the stable ( prod ) version.

I’d appreciate if someone can direct me to how I could investigate the error



Just putting more information - I’m still not able to get this to work reliably. I tried staging and then I removed everything and moved back to dev - still getting the same issue - though I am not even adding erpnext ( just frappe ) .

I’ve now tried with 10( prod ) , 11 ( staging ) , 12 ( dev ) and still get the same error viz does not login but no errors in log.

Can someone help me about how to increase the logging ?



You really need to look at the logs, of which there are several on your ERPNext install on the filesystem not just the front end. Also try clearing your cache in browser and bench clear-cache command too

Location of log files depends on your methy of install.