General Ledger report is returning 502 bad gateway error

I’m facing an issue where general ledger is not loading when accessing it directly from the accounting workspace shortcut. Trying to inspect it’s API request it’s returning 502 bad gateway error. But when it’s accessed via a voucher for example journal entry, payment entry, sale invoice, the ledger report is well loaded with Voucher type and number filter per voucher. When I clear the filters it reverts back to it’s original error of 502 error. I 've tried to increase the timeout in the frappe configs it still fails and also tried replicating the query sent to the bench console it’s also working as expected the data are being returned with no error. The frappe is deployed on a VPS and it’s still in development. Any help on this matter will be highly appreciated Thanks!

Hi Frappe Community,

I’m facing a persistent issue with the General Ledger not loading correctly from the accounting workspace shortcut, resulting in a 502 error. Interestingly, it loads fine when accessed via vouchers but reverts back to the error when the filters are cleared.

Despite numerous troubleshooting attempts, including increasing the Frappe configs timeout and replicating the query sent to the bench console, the problem remains.

I’m at a loss here, so any advice, suggestions or shared experiences would be greatly appreciated. Could this be a bug? If so, how do I report it effectively?

Thanks in advance for any help.