Get Bench requirement error when installing ERPnext

I am getting following error in Ubuntu 20.04.4 LTS server using the command sudo python3.8 -m pip install frappe-bench

ERROR: bench 5.0.0 has requirement Jinja2==2.10.3, but you'll have jinja2 3.0.3 which is incompatible.
ERROR: bench 5.0.0 has requirement requests==2.22.0, but you'll have requests 2.28.1 which is incompatible.
ERROR: bench 5.0.0 has requirement setuptools==40.8.0, but you'll have setuptools 63.2.0 which is incompatible.

But if I use the command `sudo python3.10 -m pip install frappe-bench’ I am getting this error

Traceback (most recent call last):
  File "/usr/lib/python3.10/runpy.py", line 196, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib/python3.10/runpy.py", line 86, in _run_code
    exec(code, run_globals)
  File "/usr/lib/python3/dist-packages/pip/__main__.py", line 19, in <module>
    sys.exit(_main())
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/main.py", line 73, in main
    command = create_command(cmd_name, isolated=("--isolated" in cmd_args))
  File "/usr/lib/python3/dist-packages/pip/_internal/commands/__init__.py", line 96, in create_command
    module = importlib.import_module(module_path)
  File "/usr/lib/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 883, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3/dist-packages/pip/_internal/commands/install.py", line 24, in <module>
    from pip._internal.cli.req_command import RequirementCommand
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/req_command.py", line 15, in <module>
    from pip._internal.index.package_finder import PackageFinder
  File "/usr/lib/python3/dist-packages/pip/_internal/index/package_finder.py", line 21, in <module>
    from pip._internal.index.collector import parse_links
  File "/usr/lib/python3/dist-packages/pip/_internal/index/collector.py", line 12, in <module>
    from pip._vendor import html5lib, requests
ImportError: cannot import name 'html5lib' from 'pip._vendor' (/usr/lib/python3/dist-packages/pip/_vendor/__init__.py)

What is the problem and how to solve it?

Regards,

Hi,

May we know which version of ERPNext you are trying to install?

Has sudo pip3 install frappe-bench been tried?

I am trying to install ERPNext 13.

As you may have noted when I issue the command sudo python3.10 -m pip install frappe-bench I am getting errors listed above.

As I am quite new to working in Ubuntu and Python I don’t know how to solve it.

Regards,

The error suggests that the html5lib library is missing. Perhaps try installing that from pip or apt and try again.

1 Like

Hi, Any update on this issue?