Getting error installing a local site

I am trying to install erpnext in the local system
OS - Kali VERSION=“2021.2”
My sql version - mysql Ver 15.1 Distrib 10.5.10-MariaDB
Redis server v=6.0.11
Node version v14.17.0
install the standard (Developer) branch
when I run the command
bench new-site kali.erpnext.cerulean
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
Traceback (most recent call last):
File “/usr/lib/python3.9/”, line 197, in _run_module_as_main
return _run_code(code, main_globals, None,
File “/usr/lib/python3.9/”, line 87, in _run_code
exec(code, run_globals)
File “/home/bench/frappe-bench/apps/frappe/frappe/utils/”, line 104, in
File “/home/bench/frappe-bench/apps/frappe/frappe/utils/”, line 19, in main
File “/home/bench/frappe-bench/env/lib/python3.9/site-packages/click/”, line 829, in call

The entire error code is given in ERPNEXT error code -
The same thing happens when I try to drop the site.

What could be a possible reason - I am using maria db and have a database called bench and all. Since this is internal facing I have the odd domain name - kali.erpnext.cerulean.

Can someone please suggest a way out I have been struggling with this for the last 2 days.

already show that in your log last of line

pymysql.err.OperationalError: (1698, “Access denied for user ‘root’@‘localhost’”)

you should ensure your step to create db and authorized account has right to access (create, delete, drop etc).

Wow - thanks for such a quick response. What would be the steps to resolve the issue ?
In the database section I have created a database “bench” and added a user "bench " granted it all privileges - after getting the error I have granted the root permission to all the databases.
I have gone through the forums and didnt get anything concrete enough to solve this.

Note -I tried this - mysql -u $(whoami) - and got the error -
ERROR 1045 (28000): Access denied for user ‘bench’@‘localhost’ (using password: NO)

I am hosting other sites locally not exposed over the net - so there are other databases and tables - what can be a way out ?

mariadb has changed , seem from 10.3 or 10.4 version , now mariadb root account can access without password, this may be a tricky point as I have headache in previous test.

so create another user is preferred (bench in your Error log)

what I recommend is, before install ErpNext / Frappe, well test the preparation.
like in Mariadb, you can ensure the account has properly right to access before you go on next step:

mysql --user $username --password $dbname --host=localhost --protocol=tcp --port=3306

update the $variable to your setting, it will ask the password for auth, if success you should access into database

seem you are not using script, I also not recommended in this method.
manual install can make you aware the step walkthrough. however, you must create the site with parameter according to $dbname, $dbuser and $dbpassword, that you can find it later.