Getting Frappe login instead of ERPNext login

I have installed ERPNext 13.52.0 via single compose docker. Now I get the frappe login, not the ERPNext login. How can I get the latter?

Have you tried logging in? I think the Frappe/ERPNext logins are one and the same. A new install of ERPNext v14 I have shows a Frappe login page but the ERPNext logo.

Once logged in I see the usual ERPNext workspace

Yes, I have tried logging in, with my usual credentials. I have restored the database from a v13.16 installation. However, the login fails.

Did you use “–install-app erpnext” with your bench new site command? Or did you install erpnext into the site later? If not, you will have frappe only and no erpnext. I believe this is necessary even if you are going to restore your database later.

I would recommend starting over and using v13.16 in your docker compose instead of v13.52. Then, after site creation, restore your database to the same version in the backup. Once you’ve established it’s working, then you can upgrade to latest and bench migrate.

Yes, I have installed erpnext into the site.
I need v13.52 because it has some new functionality. However, v13.52 needs a single compose docker installation (with a combined frappe and erpnext-backend container), while v13.16 has a docker installation with separate frappe and erpnext backend containers. So I do not see how to upgrade from v13.16 to v13.52 within one and the same docker compose project. Therefore, I first have installed a fresh v13.52, then restored the v13.16 backup into it, and then called bench migrate.

I see- yes, that would be a lot of work to get a multi-image going first, then moving to single-image. And what you describe should have worked, I believe.

Can you log in as the administrator? You can reset the password with bench --site [sitename] set-admin-password [password] if needed. If you get logged in you could look around and find some other clues as to what’s going on.

sites volume and mount location didn’t change in any image, data can move from even first multi images containers to recent one. It’ll not need any data copying you can just start new containers with single image instead of old multi image using same volume mounted at same location.

Here’s a guide for migration

You can build v13 images, just use build-arg with py and node versions from here

Thanks, yes, set-admin-password and then logging in as Administrator works. But then I get a fresh ERPNext installation. So it seems that restoring the backup did not work. I have repeated the restore and migrate process, and now everything works!