Git status on fresh install returns millions of files marked as "modified"

I ran the easy install script (ubuntu 16.04 running inside of an LXD container) and would expext a git status in ~/frappe-bench/apps/erpnext[frappe] should report back my branch to be up-to-date with the remote upstream/master.

Instead a very long list of files (feels like practically every file) is marked a modified

The same happens in frappe as well as erpnext. Now, what would be the appropriate action here?

git commit && git pull upstream master comes to mind.
Does that sound reasonable?

try git checkout upstream master

If you change permissions after checkout this might happen.

Try git reset --hard

I did not do anything really, the only thing that comes to mind is … I followed advice from someone to create a frappe user before running the script (which I ran then from the user [ubuntu] that exists in an LXD container by default) Maybe this has messed with permissions?

Will look into this. thanks for now