Global Search for "Item Code" not working

Hi There,

We have just updated to V8.0.8 yesterday, and tried working on the Global Search.
But unfortunately, it is not working for Item Code even if it was set in the Global Search.

I have tried with the demo with V8.0.0-beta and it is working fine.

Did i miss something about setting “in Global Search” ?
Below are the screenshots for reference.



Can you share the Item master with value Item1? For the fields which are not searchable for now, please ensure that in the Customize Form, if field “In Global Search” is checked for it.

1 Like

Hi Umair,

Thank for your reply…
Does it mean we need to check “in Global Search” all the fields of the item to make it searchable?


@umair, below is the screenshot for your reference.

Item code is already checked “in Global Search”

Finding same thing here, I can search by item name without issue (i.e. 8" Wheel Nut) however when searching by item code (i.e. 100-823) no results are returned. I can confirm the item_code field has ‘In Global Search’ selected (by default).

Checked however all the items appear to have the item name and item code being the same (i.e. mobile) so not a fair comparison. Cannot add test item either, so unable to compare. Is anyone able to test and advise?

Anyone else experiencing this issue?

my problem solved after update to last version .

Updated to latest, still same issue. Created Github issue.

I’m having the same issue, I can not find the item code on global search. My version is updated and global search is marked on the field. Any Idea?

Solved it with this doctype