Google integration - error message: password too long


I have successfully set up the OAuth and Google API keys with the correct redirects.
In the Google Contacts integration setup, I can define the email address and give authorization to the system to synch the contacts.

But, when I click save, I get the following error message:
Password cannot be more than 100 characters long

So I’m a bit lost here because there is no password field to be filled…

Can you share a screenshot? What is the error message in the Console of the browser?

When I push the button Sync Contacts, I get a popup message bottom right that it’s syncing, but the data in the Google Contacts store doesn’t get updated.

same error here, could you solve it? regaras

No luck so far

The problem is related to the api you has to enable it

search for google calendar, contacts, drive api and enable it

And the error message go out


+1 Same error when I try to setup.

In the API credential URI’s, change to the following:

https://(your site)?cmd=frappe.integrations.doctype.google_contacts.google_people.google_callback

Google changed the API Contacts to People, so changing this resolved the password issue.

Only now I get a cryptic Server error when trying to push contact data to Google:

TypeError: Got an unexpected keyword argument “parent”

Same issue for me since 6 months trying while following all the steps : google credentials, api, etc.
As I press the Authorize google’ button, I get the tokens, but As I try to save the configuration : Erpnext says :
Mot de Passe ne peut pas contenir plus de 100 caractères
(Password too long). The password is the refresh token.

When I press the “synchronize” button, I get a 410 error (Meaning the script can’t fetch events from google server).
Does anyone can use the gsuite agenda feature?

Thanks for your replies.

The password length error has been covered by the next releases, but there is still a 410 error (Meaning the script can’t fetch events from google server).
Do someone else get the same issue ?

1 Like

The same error is shown for the Dropbox integration


Don’t expect that someone will help you or maybe fix the f problem. Normal thing here. Just push new versions like it’s new Samsung or iPhone. Lol.