GST not auto-calculating

GST rate and tax amount not auto-calculating. The respective tax items are getting populated in the tax field on selecting an item/customer.

For own state customer CGST and SGST is showing up. For other state customer IGST is showing up. But tax rate and values are not getting populated.

This should work fine. Maybe some configuration is missed out.

  • Where have you set your tax rates? Can you share screenshot?
  • What are the tax rates setup in your default tax templates.
  • If tax rates are set in Item Tax Template, Is you Item Tax Template set in Item Master?
  • If taxes are set in Item Tax Template and is set in Item Master, is it getting fetch in the Sales Invoice here? Share the screenshot of the Item Details with Item tax template getting loaded.

If you ensure above steps are intact, taxes should get loaded.

Can you please refer to the specific docs here and check it its configured and loading:

  1. Item tax template set in Item (Docs)
  2. Item tax template getting loaded for item in Sales Invoice (Docs)

Thank You for the response.
GST Rate setup

Assignment to Item under Item Tax

Still the sales invoice is not auto loading the tax rate.

It should get set in the Sales Invoice item:

Is that happening when you create a new invoice?

Ahh… Yes, If I update the item tax template here, the tax value is appearing. But the problem is non of my existing tax templates are listed here neither the one that has been already assigned to the item. So had to try by creating a new item tax template from the option “Create a new item tax template”.

Why is the assigned item tax template not appearing here?

Item tax templates are required to be created for each company.
Make sure you have created it for Turqosoft.

1 Like

Yes, I have created it for each company.

Any other checkpoints that I need to be aware of?

Updating the item category column either at Item Group Level or Item level seems to be solving the issue. The system is auto-fetching the rates and calculating the gst amount correctly. But, is this this the right method? I haven’t seen this method in any of the documents or training videos.