Header is not printing on pdf in ver13 of custom print format

Hi all,

I added some text in header it is showing on page but when i click on pdf ,the headers are not showing in custom print format.
Below is my Header section Code.It is working in ver12 but not working in ver13 when i click on pdf.Please help me.

{{doc.customer}} {{doc.get_formatted("delivery_date")}}


1 Like

I wrestled hard with this one, but upgrading to the latest version of wkhtmltopdf (0.12.6) with the qt patches fixed it. Here is the process I followed:

I used wget to download the latest version of it from here: (in my case the amd64 debian version)

And then I unpackaged it. I had to install a few dependencies (xfonts-75dpi), but this fixed it so that now running this from command line:
sudo wkhtmltopdf -V
Results in this:
wkhtmltopdf 0.12.6 (with patched qt)

I am running ERPNEXT v 13 on a google hosted debian vm. The problem is that the version of wkhtmltopdf that was installed on my vm was not compiled with the qt patches and could therefore was not able to build a pdf with the header or footer options. (You can read the FAQ on the download page I linked above for more info.)


1 Like