Help Enabling Developer Mode

I have seen several references on the forum and the documentation to Developer Mode. I have tried to enable Developer Mode on one of my test ERPNext sites. However, I don’t see “Developer” listed on the setup page (like this post describes), nor do I see a “Developer Icon” on my Desktop (as this page says I should). What am I missing?

My frappe-bench/sites/my-site-name/site_config.json contains the following line: ““developer_mode”: 1,”

I have tried running “bench clear-cache” as well as using the “reload” button from the interface menu.


try “developer_mode”: 1 instead of ““developer_mode”: 1,”
it should be like this
“db_name”: “bcad64afbf”,
“db_password”: “v3qHDeVKvWVi7s97”,
“developer_mode”: 1
“db_name”: “bcad64afbf”,
“developer_mode”: 1,
“db_password”: “v3qHDeVKvWVi7s97”

I have the SSH config after the “developer_mode” definition, so I need the comma to have valid JSON correct?

“db_name”: “something”,
“db_password”: “somepass”,
“developer_mode”: 1,
“limits”: {
“space_usage”: {
“backup_size”: 2.0,
“database_size”: 14.44,
“files_size”: 2.0,
“total”: 18.44
“ssl_certificate”: “/some/path/mycert.pem”,
“ssl_certificate_key”: “/some/path/mykey.pem”

I am running a “production” setup with nginx, not the build in webserver. Is that not compatible with developer mode?

yes comma after 1