(HELP) Kubernetes installation process

Hey there !
I was trying to install erpnext with kubernetes with instructions from https://helm.erpnext.com/
But i am not able to install successfully
I think instructions are not properly guided there
So i follow some blogpost guide but failing continuaslly and not updated with new volume structure or maybe i am not getting understand something .i am trying for previous 10-12 days but not getting installed
Can someone give me yaml files to install letest helm version and how to also

I’m curious to know what all things you tried for all this time? Can you share any commands, errors, logs or output from past 12 days?

Note for future readers: Share something more than frustration which can be helpful to debug. Or it results into more time wasted on forum discussion. This post was replied after 7 hours, the reply is not meaningful, the reply is just asking for more output which could have been shared with the first post saving 7-8 hours.

I don’t expect much change anyway. I just expressed my observation. Mods can edit/delete this post if they feel necessary.

edit: The reply will mostly have unformatted logs. I’ll have to read through the unformatted logs anyway.


I am sorry! I thought what i did was all resulted in errors and failure so may be i was not getting it right so i lets ask straight for help
You are right i am frustrated with constantly trying to install and getting errors
I am installing it on wsl ubuntu
What should i provide logs or yaml files ?
Because first thing is instructions on helm is not properly guided where to put what names is not properly formatted and also what after what is also not instructed
I was getting pvc pending status with those instructions
So after that i followed test script instructions but there is error in persistent strorage claim because after many trial and errors i got that there is difference in name where we should provide claim claim name is nfs in one file where other has erpnext-upstream
So after that i followed very strong fingers instructions on his blog but it got me error of worker and logs volume are not created and resulted in pending status of volume claim
So after many research i got his github branch with revised introduction in beta branch but
Now i am getting mariadb cluster is not reachable error all pods showing running but site is not creating

Tell what should i provide

sam@DESKTOP-9HQC1RC:~/erpnext-stuff$ kubectl replace --force --namespace erpnext  -f create-site-job.yaml
job.batch "create-erp-site" deleted
job.batch/create-erp-site replaced
sam@DESKTOP-9HQC1RC:~/erpnext-stuff$ kubectl logs --namespace erpnext -f job/create-erp-site
Attempt 1 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 2 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 3 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 4 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 5 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 6 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 7 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 8 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 9 to connect to mariadb.mariadb.svc.cluster.local:3306
Attempt 10 to connect to mariadb.mariadb.svc.cluster.local:3306
Connection to mariadb.mariadb.svc.cluster.local:3306 timed out
Site localhost already exists
sam@DESKTOP-9HQC1RC:~/erpnext-stuff$ kubectl apply --namespace erpnext -f site-ingress.yaml
ingress.networking.k8s.io/our-site-ingress created
sam@DESKTOP-9HQC1RC:~/erpnext-stuff$ kubectl port-forward --namespace kube-system svc/traefik 8080:80
Forwarding from -> 8000
Forwarding from [::1]:8080 -> 8000
Handling connection for 8080
Handling connection for 8080
Handling connection for 8080

this means it’s not able to connect to Mariadb

this means you’ll have to force create site or delete existing directory and database for site and try again.

the ingress in documentation assumes you’re using kubernetes/ingress-nginx as ingress controller and not anything else

This is my 3rd attempt with this error and every time i deleted both namespaces
I don’t know what is wrong

Do you want to see my yaml files ?

can you confirm connection to Mariadb? try to enter the Mariadb shell from a pod in cluster. can you confirm the connection?

if you don’t confirm the connection you’ll spend more days going around in circles.

second thing i mentioned is, if the site directory exists in volume, it won’t be created again. you need to force create it.

refresh, restart, reinstall, restore, reload, clear cache doesn’t always work. I don’t think you’re doing anything different from your first attempt.

by the “predicted unformatted dump” you shared, I can see that you don’t even read the responses from the previous commands and issue the next commands (thanks yashodhan for taking the effort to format the dump)

Hope someone else from community can help you.

try the updated helm chart from scratch.

1 Like

Yes i tried so many things
I learnt so many things also but in the end i could not get it working so i was being furious but i will try with your new updated chart because for some 3-4 days i was busy i will report you tomorrow :slightly_smiling_face:

Sorry to say but still unable to install
And i think making custom-value.yaml is asking for persistent class
But in the last i got pending status on clusters
I know i am not getting it how to do

My request is can someone make video guide for it because it will not just help me but also to those who are not so advance in those area

Tried second time now stuck at container creating on frappe bench erlnext conf bench pod

kubectl describe pods
kubectl logs
kubectl describe pvc

above commands can help identify what’s happening when it shows container creating.

share your KUBECONFIG and access to your cluster with me and I’ll take a look.

On TeamViewer?

Or ssh ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.