Help Needed - Metabase Setup

Hi, we tried to setup Metabase in our Google cloud where our ERPNext instance is running( I will list out the procedure we followed.
1.First we installed Docker by this guide Docker installation
2.Installed Metabase by this Metabase Docker Guide
3. Commented out the line bind-address = in /etc/mysql/my.cnf .
4. Opened ports 3000 and 3306.
5. Added mysql queries
CREATE USER ‘user_remote_R_only’@‘localhost’ IDENTIFIED BY ‘myStrongeSTpassword’;
CREATE USER ‘user_remote_R_only’@’%’ IDENTIFIED BY ‘myStrongeSTpassword’;
GRANT SELECT ON . TO ‘user_remote_R_only’@‘localhost’;
GRANT SELECT ON . TO ‘user_remote_R_only’@’%’;
flush privileges;

But when i access , nothing is loading, don’t know where went wrong.

hi @raghu9

  • did you opened the port 3000 as per Link. Make sure you opened this port which can be accessible form any source ie.,
  • Run this command post the result docker ps
  • try this guide to understand more about your listening ports. Link
1 Like

Thank you sir, this solved the problem. Issue was with incorrect firewall rules.

If you can please explain how you corrected…

I ran a clean uninstall of Docker and reinstalled everything.
In previous setup I only mentioned tcp port 3000 in firewall rules, this time i opened both tcp and udp ports.