Help needed on Development version

Hello team,

I have tried two month now to install development branch without any success

any one to help or give me a working tutorial because i have tried GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps
and GitHub - frappe/erpnext_vagrant: Vagrantfile and Bootstrap for creating a dev environment for ERPNext both not working

Please i realy need help am about to give up on this wonderful solution

Thank you,
Ian Manyama

Please be more specific and someone could help you ,

Steps you followed to install dev branch setup ?
What is the error you are getting ?
Are you trying to install it on a VM ?
Which OS and which version ?

Try displaying these things and someone would help you .


1 Like


Okay thank you,

I am trying to install on VM, Ubuntu 14.04

I have downloaded development version from this page

and istall it in my VM

but i can not access the site on my browser using provided link, i have tried with production version and its working

What is the error you are getting when you try to access erpnext with your browser ? If it works with production version , after installing production setup , try running these commands

bench switch-to-develop
bench update

This might help you


When i try to access in the browser below is the screenshot

and i have tried to run bench switch-to-develop but am getting below error

Thank you

Hi ,

@vjFaLk could help you solve this issue .


@Ian_Manyama Hey, you need to first login into the development VM by using the username and password both as frappe, and then go into the frappe-bench directory and run bench start. Sorry for not adding these instructions on the download page.

1 Like

Helli vjFaLk

Thank you for quick reply, i have done as you instruct this is my vm screenshot

But still i can not access application in browser i have tried using both http://localhost:8000/ and http://localhost:8080/

Thank you

Hmm, let me have a look at this issue. Basically, it seems the 8000 port isn’t being forwarded, see if you can tweak your VM settings to do so.

1 Like


Yes i think it i s about port forwarding, i have checked my VM network setting, below is the screenshot

I have still yet to figure how to solve this

Thank you


Your VM must be reachable by an IP Adress.
Then you reach the site with http://IPofVM:8000.

Hello Idat,

I have used IP and still the same can not reach the application

Thank you,
Ian Manyama

With my virtual machine, I need to use http://localhost:8080

It looks like yours is listening on port 9000. Try http://localhost:9000

hello Ben,

Even port 9000 is not responding

Thank you

@Ian_Manyama Sorry for the late response, it was as I was thinking, the 8000 port wasn’t forwarded.

In the settings screenshot above, you just need to add a NAT rule (from Port Forwarding) that forwards 8000 port to 8000 or any port you would like.

Refer to this tutorial :