(Help) Trying to install v13 for Production with Portainer and NginxProxyManager on Ubuntu 20.04.4

So far I’ve managed to get ERPNext installed on this machine (Physical box) and working when it is the only thing running, no Portainer or NPM, by using AName to direct to this box. As soon as I try to do it with those and tweaking the configuration of ports, I keep getting various error messages 504, 502, sometimes HSTS errors.

I started by following the guide from OpenSourceIsAwesome:

Using his script for installing Docker CE, NPM, and Portainer, and trying to combine it with his guide for ERPNext on a fresh server, but that one does not specifically use Portainer or NPM

I’ve tried using the Easy install script (Worked for me without Portainer or NPM installed)
for single bench, and also with Docker Swarm, also fails when adding Portainer+NPM. I’ve also tried using the Containerized Install, so far no luck.

I’ve tried using the template for the .ENV file from (now only cached in Google) How to setup & self-host ERPNext in Docker without Treafik (NGINX only)
because I’m assuming that Treafik is what was giving me the errors of “Too Many Redirects”, and we want to be using NPM instead anyway. He suggested different ports, as Portainer seems to take control of :8000 - but so far none of my changes have been successful.

NPM is successful at proxy host for other subdomains, like “npm-website-com” instead of “IP-address:81” and “portainer-website-com” from “IP-address:9000” (New users can only make 2 links in a post, so sub - for . I would really appreciate some guidance with this, as I’m pretty new to Docker. I’ll gladly provide whatever info is needed - I’ve made sure to # out the original text where I made any of my changes.

1 Like
git clone https://github.com/frappe/frappe_docker
cd frappe_docker
cp example.env .env
docker compose -f compose.yaml -f overrides/compose.mariadb.yaml -f overrides/compose.redis.yaml -f overrides/compose.noproxy.yaml config

This command will generate yaml that runs without traefik.

I read somewhere that NPM doesn’t work in docker swarm mode. I don’t know if that has changed now.

I tried this after changing


and I got :
unknown shorthand flag: ‘f’ in -f
See ‘docker --help’.
with ------>>>> help commands

as regular user and sudo.

I tried adding a hyphen, eg: docker-compose -f…etc
and it returned:

ERROR: Invalid interpolation format for “image” option in service “x-backend-defaults”: “frappe/frappe-worker:${FRAPPE_VERSION:?No Frappe version set}”

I’m clearly missing something

docker compose without the hypen is Compose V2


Ok, with a fresh git clone, I don’t see anything in the .env or the compose.yaml that has $$$$, I’m on docker-compose version 1.25.0-1

Before I start messing around again - what specific variables should I change in which files if I want to be using this Portainer setup and Let’sEncrypt?

If it helps for determining what to put for the ports, my current setup is these containers across 2 stacks:

are you using portainer in docker swarm mode?

nginx proxy manager works in swarm mode?

No, not swarm - that kinda messed things up beyond my ability, so I wiped the machine and started absolutely fresh

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.