Help with view - Item module

Hi ,

I want my custom field to appear here after the status field , please help .



Please add your custom field in item_list.js

1 Like

Hi @umair ,

Many thanks for responding I added my custom field to item_list.js , but still could not see that get listed , restarted bench , cleared cache but still not able to see .

Please help


Please check if field name entered is valid. If issue continues, share script and exact field name.


Have you checked “In List view” for your field from customize form??

1 Like

Hi @Nishant_Jariwala . Yes I did that already .

Any help ? Thanks

Hi @umair . Thanks for the reply , my script ,

frappe.listview_settings['Item'] = {
	add_fields: ["item_name", "stock_uom", "item_group", "image", "variant_of",
		"has_variants", "end_of_life", "disabled", "total_projected_qty","grade"],
	filters: [["disabled", "=", "0"]],

My custom field name - grade … Please help

Have you rebuilt after making the changes?

bench build

1 Like

Hi @Muthu
As per my understanding only first 4 fields in the list cab be seen in the list view.
Try to reorder your list

rappe.listview_settings['Item'] = {
	add_fields: ["item_name", "stock_uom","grade", "item_group", "image", "variant_of",
		"has_variants", "end_of_life", "disabled", "total_projected_qty"],
	filters: [["disabled", "=", "0"]],

And in the same way try to remove “In List view” from other items like image, variant_of etc.

Ruchin Sharma

1 Like

Hi @Ben_Cornwell_Mott. Thanks for reply . I have a doubt ,will running bench build command brick my development ?


Hi @ruchin78 . Many thanks for reply ,I tried again and it worked thanks.

Many thanks for all @umair , @Ben_Cornwell_Mott , @Nishant_Jariwala , @ruchin78 .

Please close this thread.