Hidden attribute doesn't work if the field is virtual as well in Child table

The hidden attribute of a docfield in child table is not working if the field is virtual as well. Please check this and how can I hide it? Even setting property from the client script is not getting to take effect on this thing if the field is virtual.

Hi @Abhiraj_Tulsyan,

Okay, so we looked at the child table and tried using a virtual field with the “hidden” setting, but it didn’t work. However, you can give it a shot using a client script.

frappe.ui.form.on('Test Child Table', {
    form_render(frm, cdt, cdn){

Please set the child doctype and field according to the scenario.

I hope this helps.

Thank You!

This form_render event is not even mentioned in the doc

Please apply it and check it.

Only you have to add your child’s doctype name and field name.

I’ll do that. but please update docssssssssss

The doc does need some updating, but form_render is already there.

You could also look into the missing frappe manual by Hussain