Hide Auto ID in List view and form

Hi team,

i am trying to hide the Auto generated ID in “List view & also in form”. But it is not working. Please find the below screenshot.


In form Dropdown value, ID is displaying along with Actual vaue in list

Thanks in advance!!!

Hi Balaji,
I am also new to frappe world. I tried few things but could not find any solution.
I think if you can find a way to set the visibility of ‘id’ field to ‘hidden’ then it should do the trick.

Following is what I tried, but not sure if the ‘frm.set_df_property’ has the following parameters. But there should be some way. May be this helps you.

frappe.ui.form.on("Test DocType", {
     	refresh(frm) {
            frm.set_df_property('name', 'visibility', 'hidden');
    
     	},
     });

Balaji,
Additionally, more important what are you trying to achieve with hiding this information?

When a new record is created frappe creates a ‘id’ automatically, and this id is also visible in the URL.
e.g as follows-
image

You can hide showing the ‘auto generated id’ in the list view by giving another field’s name, in the ‘title field’ under the ‘view settings’. The screenshot is shown in the following section.

And for the second screenshot- just ‘deselect’ the following option in the linked docType. This will stop showing the auto generated id.
image

Hi Praty,

Yes. it works!!! Thanks.

Write this code on doctype_name_list.js or on client script list.

frappe.listview_settings["Doctype Name"] = {
	hide_name_column: true,
	hide_name_filter: true,
}

Just wanted to note that the above code in doctype_name_list.js will only work if the Doctype has a title field set

frappe.listview_settings["Doctype Name"] = {
	hide_name_column: true, // this part
	hide_name_filter: true,
}