Hide or prohibit the entries

How to hide or prohibit the access of following entries:

1: Use of “multi-level BOM” in production order.
2: Purpose in stock entry “Material issue”, “material transfer” and “repack”.

Try Customize Form

I have tried to remove “Use Multi-Level BOM” in customization form, but it appears immediately on last row.

dont remove original field… just hide it…


How to hide? There was no such option in customization. ( Available Types: Attach, button, check,code,column break,currency,data,date,read only,float,link… )

there was a check box for it as i remembered

It works fine.

I have also tried to hide “Use Multi-Level BOM” from production planning tool, but in customize form there is no production planning tool.
Could you please help me?

I have hide “Use Multi-Level BOM” from stock entry(manufacture) using customize form, but by default it is taking raw material as input. how to make it unchecked by default?


Set default as 0

Thanks for your response.

I have set 0 as default value for “perm level” and “default”, I have deleted the cache memory and restarted the server PC.
This could not solve the problem.
Please suggest me.

Maybe you will have to set it via a custom script.

frappe.ui.form.on("Production Order", "onload", function(frm) { 
  frm.set_value("from_bom", 0);

1 Like

Thanks Rushab.
I am not aware of programming languages.
Could you please tell me what was custom script and how to add above mentioned code to it?

In which case you want to uncheck “From BOM” field? On changing the purpose to some specific value? As far as I know, “From BOM” is loaded as unchecked on a new Stock Entry.

I don’t want to uncheck “From BOM” field, I want to hide and uncheck the “use multi-level BOM” in stock entry(manufacture). I have tried to do that in custom field, set 0 as default value but it is checked by default.

@santosh_baburao In Stock Entry (Manufacture type), on selection of Production Order, system fetches and sets value of “Use Multi Level BOM” from Production Order. Hence, you have to uncheck “Use Multi-level BOM” in Production Order itself. In Production Order, you can set default value of that value to zero.

I had unchecked in production order and set 0 as default, it was not working.
Now, I have reinstalled the bench and recreated all masters and set 0 as default value in production order and stock entry, it is working fine.

Thanks for your response.